bluespec.com Forum Index bluespec.com
Bluespec Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

ivl error after installing Xilinx ISE 14.4

 
Post new topic   Reply to topic    bluespec.com Forum Index -> Tools: Other
View previous topic :: View next topic  
Author Message
sangook



Joined: 23 Nov 2011
Posts: 3

PostPosted: Thu Mar 14, 2013 5:05 am    Post subject: ivl error after installing Xilinx ISE 14.4 Reply with quote

Hi, I have been able to compile and simulate with bsc and iverilog compiler on bluepsec workstation with no problem at all until I installed Xilinx ISE 14.4 last night.

After that, when I try to compile and simulate with "Compile to verliog" option, error occur as shown below.

I use ubuntu 12.04. Please help me out.

Thanks in advance.

=======================================================================
Compile Link and Simulate the Project...
+ bsc -u -verilog -elab -vdir . -bdir . -info-dir . -keep-fires -sched-dot -p %/Prelude:%/Libraries -g mkTb Tb.bsv
checking package dependencies
All packages are up to date.
+ bsc -e mkTb -verilog -o ./out -vdir . -vsim iverilog -keep-fires ./mkTb.v
/usr/lib/ivl/ivl: /opt/Xilinx/14.4/ISE_DS/ISE/lib/lin/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/ivl/ivl)
/usr/lib/ivl/ivl: /opt/Xilinx/14.4/ISE_DS/ISE/lib/lin/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/ivl/ivl)
/usr/lib/ivl/ivl: /opt/Xilinx/14.4/ISE_DS/ISE/lib/lin/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/lib/ivl/ivl)
ERROR: cannot compile Verilog files
Compile/Link/Simulate finished
The project ./simple_proc.bspec is saved.
Back to top
View user's profile Send private message
quark
Site Admin


Joined: 02 Nov 2007
Posts: 496

PostPosted: Thu Mar 14, 2013 1:06 pm    Post subject: Re: ivl error after installing Xilinx ISE 14.4 Reply with quote

The setup script for Xilinx is probably setting a value for LD_LIBRARY_PATH in your environment. The Xilinx installation has its own local copies of the C++ libraries, as you can see in the message:
Code:
/opt/Xilinx/14.4/ISE_DS/ISE/lib/lin/libstdc++.so.6
and this is shadowing the local version of libstdc++ that is installed with your OS.

You can fix this by clearing LD_LIBRARY_PATH in your environment when you run Bluespec tools. You can either do this manually, or insert a command into the wrapper script that runs BSC. Alternatively, you can write a wrapper for Xilinx tools, so that the setup script is only executed when you run the Xilinx tools (and any changes it makes to the LD_LIBRARY_PATH are only visible inside the wrapper).
Back to top
View user's profile Send private message
quark
Site Admin


Joined: 02 Nov 2007
Posts: 496

PostPosted: Thu Mar 14, 2013 1:12 pm    Post subject: Re: ivl error after installing Xilinx ISE 14.4 Reply with quote

Looking at the message closer, it appears that BSC is OK using Xilinx's C++ libraries; it's iverilog that is having the link problem. But the diagnosis is the same.

Since it's Xilinx that isn't playing well with others, I suggest creating a script or function to call those tools and their setup scripts in a sandbox shell or environment. I'm told that this is a common practice for using Xilinx tools.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    bluespec.com Forum Index -> Tools: Other All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum
bluespec.com topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP