bluespec.com Forum Index bluespec.com
Bluespec Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Bluespec internal compiler error

 
Post new topic   Reply to topic    bluespec.com Forum Index -> Tools: Bluesim
View previous topic :: View next topic  
Author Message
eschung



Joined: 14 Jun 2007
Posts: 14

PostPosted: Thu Aug 16, 2007 2:09 am    Post subject: Bluespec internal compiler error Reply with quote

Hello all, attending the workshop has inspired me to try out my design using Bluesim. After generating the *.ba files, I run into this error:

bsc -sim -e mkBluesparcMP *.ba
Internal Bluespec Compiler Error:
Please report this failure to your Bluespec technical contact.
If you do not know your contact, you may email [email protected].
The following internal error message should be included in your
correspondence along with any other relevant details:
Bluespec Compiler, version 2007.03 (build 10564, 2007-03-30)
BinData.Bin([a]).readBytes: 79

The top-level mkBluesparcMP.ba file appears to be causing the problem. There are other *.ba files as well and I can successfully generate those sub-modules in bsim. But anytime I include mkBluesparcMP.ba in the search path, I get the same error as shown above.

Thanks,
Eric
Back to top
View user's profile Send private message
jnewbern



Joined: 18 Jul 2007
Posts: 71

PostPosted: Thu Aug 16, 2007 7:39 am    Post subject: Internal error reading .ba file Reply with quote

Eric,

Thank you for reporting this problem.

I want to confirm that you are regenerating all of the .ba files and performing the link command (bsc -sim -e ...) using the exact same compiler that was used to create the .ba files.

How large is this testcase? Are you able to send me the source code so that I can reproduce it and debug the problem?

Thank you,
Jeff Newbern
Back to top
View user's profile Send private message
eschung



Joined: 14 Jun 2007
Posts: 14

PostPosted: Thu Aug 16, 2007 10:37 am    Post subject: Re: Reply with quote

Hi Jeff,

I am using the same compiler (3-30-07) for generation as well as linking. Unfortunately, I haven't been able to isolate the cause to a single identifiable test case. The problem happens to emerge at the top-level when I compile the whole thing altogether. I will send you a tarball of the source.

Eric
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    bluespec.com Forum Index -> Tools: Bluesim All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum
bluespec.com topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP